Xcode 9 crash during uploading app to App Store

In my project the Xcode 9 crashes during uploading to App Store (or exporting to disk, it does not matter). I have found that it may be caused by cocoapods or some kind of external frameworks bug, because on my other projects which do not use cocoapo...
more »

2017-09-30 15:09 (0) Answers

Why does `pod install` change the PODS_ROOT path?

Whenever I run pod install, CocoaPods tries to change the PODS_ROOT/... to PODS_PODFILE_DIR_PATH/... in the build phase. I'm not sure why this value is changing just for my Cocoapods setup and not for my other team members. Does anyone know why this...
more »

2017-09-27 19:09 (1) Answers

App installation failed Error

When I installed alamofire pod into my project and open workspace file and try to run project on iphone device it gives I tried putting other pod in project, the project runs on device but when I put alamofire pod to podfile the same error comes ...
more »

2017-09-20 14:09 (1) Answers

`xcodebuild archive` always performs a clean build

Every time I run xcodebuild ...params... archive it performs a clean build without reusing the cache from a previous build. While I understand the motivation behind it, it has serious consequences on my CI build times because I generate an IPA for e...
more »

2017-09-14 07:09 (0) Answers

Many errors in project with Cocoapods

I am trying to use CocoaPods to install some libraries written in Swift: Fusuma, TLPhotoPicker, DKImagePickerController But every time I get ~300+ errors. First, I thought, that libraries are not supporting Swift 3, but in github repositories there ...
more »

2017-09-12 16:09 (1) Answers

Lexical or Preprocessor issue. - "File not found."

Every time I update my cocoapods using 'cocoa update' command I get this error. Lexical or Preprocessor issue. - "File not found." Actually I'm having 7 targets in one project. So on updating the pods my base target that I created while creating th...
more »

2017-09-08 07:09 (1) Answers

Using CocoaPods mixed Swift3 and Swift4 pods

Using CocoaPods, most pods are still Swift3 pods, but when imported in Xcode, all pods defaults to Swift 4, which makes the compilation step fail. How can I use Swift4 pods with legacy Swift3 pods in my Podfile without having to manually changed the...
more »

2017-09-07 18:09 (1) Answers

Adding BleshSDK Framework

I have a mobile application which works on IOS platform and I am trying to add the Blesh Framework to my project.It seems like I did add the framework to the project correctly but I got a problem with building the project. Here is the exception mess...
more »

2017-09-05 09:09 (1) Answers

Syntax error in Cocoapods podfile

When I run the "pod install" command in the Terminal, I get this error message: [!] Invalid `Podfile` file: syntax error, unexpected tIDENTIFIER, expecting keyword_do or '{' or '('. # from /Users/pdenlinger/Desktop/Clima-master/Podfile:1 # ---...
more »

2017-08-31 20:08 (1) Answers

Install cocoapods before CI integration

Trying to run a bot on my Xcode Server. The project uses cocoapods, however they are ignored via git. So I am trying to 'pod install' for the bot integration via a script. That looks like this: However when I run the bot / integration I get this...
more »

2017-08-25 21:08 (0) Answers

COCOAPODS Validation i386 error

I'm trying to creat my own POD, for iOS with my codes and some external libraries and dependencies. The Example attached compiles and build the app correctly with XCODE. But when I'm about to validate with: $> pod lib lint --allow-warnings --ver...
more »

2017-08-17 16:08 (0) Answers

Can't fetch git source through Podfile

I'm trying to include a git source in my Podfile : pod 'RBStoryboardLink', :git => 'https://github.com/sedonaFR/RBStoryboardLink.git' but it gives me the following error : [!] The RBStoryboardLink pod failed to validate due to 1 error. ...
more »

2017-08-16 18:08 (1) Answers

CocoaPod pod installed but not working

I have installed the SideMenu pod for Swift. I have run all the commands in the terminal and it says the pod has installed and there is one dependency. My podfile is as follows: source 'https://github.com/CocoaPods/Specs.git' platform :ios, ’10....
more »

2017-08-14 18:08 (0) Answers

Cocoapods pod stable build setting

Is there a way to add build setting in a cocoapods pod without direct changing Pods project or other auto-generated stuff, so it will still be in place after pod install? Being specific, I need to set DISABLE_MIXPANEL_AB_DESIGNER=1 in Mixpanel pod to...
more »

2017-08-14 13:08 (1) Answers

SwiftSoup Support for Swift 4

Does SwiftSoup support Swift 4.0? I've initialized my Podfile and added pod "SwiftSoup" as instructed by the SwiftSoup GitHub repo https://github.com/scinfu/SwiftSoup before running pod install, but I'm not able to import it into my Swift files. I'm ...
more »

2017-08-13 10:08 (1) Answers

Targets within a target in a Podfile

I am trying to install the Google Mobile Ads SKD into my Xcode project. I installed Cocoapods and then initialized a Podfile into my project: # Uncomment the next line to define a global platform for your project platform :ios, '10.2' target 'Cubic...
more »

2017-08-03 17:08 (1) Answers