Xcode 8 Dependency Analysis Warning

I'm trying to remove these warnings that show up in xcode(8.3): warning: using 'ALWAYS_SEARCH_USER_PATHS = YES' while building targets which define modules ('DEFINES_MODULE = YES') may fail. Please migrate to using 'ALWAYS_SEARCH_USER_PATHS = NO'. ...
more »

2017-04-19 08:04 (1) Answers

Update libs with cocoapods break build

I'm having problems building since try update some frameworks. I use pod update and after that can't build my project. The error message is: Undefined symbols for architecture i386: "_OBJC_CLASS_$_AFHTTPSessionManager", referenced from: objc...
more »

2017-04-03 18:04 (1) Answers

No such module JSQMessagesViewController

I'm trying to import JSQMessagesViewController: import JSQMessagesViewController And it gives me the error 'no such module'. I've seen many people with this problem on the web but I can't find the solution. Here's my podfile: # Uncomment this lin...
more »

2017-03-27 20:03 (1) Answers

ld: framework not found Alamofire

I've spent few days trying to solve this issue and I am running out of ideas now. I have: Xcode v8.2.1 Apple Swift version 3.0.2 (swiftlang-800.0.63 clang-800.0.42.1) cocoapods-1.2.0 I am creating new Xcode project (Single View Application), c...
more »

2017-03-23 14:03 (1) Answers

Lexical or preprocessor issue in Xcode 8.0

I'am using react native: 0.41.2, react: 15.4.2 and cocoapods for firebase(https://github.com/evollu/react-native-fcm). I have an issue while building the code. 'React/RCTEventEmitter.h', 'React/RCTBridgeModule.h', 'React/RCTViewManager.h', 'React/RCT...
more »

2017-03-17 12:03 (1) Answers

How to port swift based cocoapods to Xamarin

I am trying to port cocoapods to xamarin. Objective C based cocoapods can be ported by converting it into a static library(.a) and subsequently converting that as binding library in xamarin studio or visual studio But Swift based cocoapods can not ...
more »

2017-03-17 00:03 (0) Answers

IOS COCOAPOD with sources

I am trying to update the CocoaPods in my Xcode project, but when I try to run pod update, it doesn't work. My podfile: source 'https://github.com/MapQuest/podspecs-ios.git' target 'FireBaseFixed' do pod 'Firebase', '3.11.0' pod 'MOCA' pod 'MapQues...
more »

2017-03-15 18:03 (2) Answers

Do I need Cocoa Pods?

I am using Ionic2 and Xcode to build an app for iOS. Question Do I need to install Cocoa Pods? I would like to keep my app as small and simple as possible, so don't want to install anything unnecessary. However, I am trying to get Firebase Authent...
more »

2017-03-13 06:03 (1) Answers

Cocoapods dependency format

I am getting an issue with Cocoapods. Please, find detailed explanation below, Initially my cocoapods was like this, Podfile pod 'Fabric' pod 'Crashlytics' pod "VKVideoPlayer", "~> 0.1.1" Then, my app needs GA (Google Analytics) so,...
more »

2017-03-10 08:03 (1) Answers

Cocopods project settings issues

I seem to have a issue with my project settings, in Xcode 8. The issue is as follows: When adding a new Pod - lets say, Pod Firebase - the install works, and adds the necessary files to my project. I can then, do @Import Firebase All is fine, up to...
more »

2017-02-28 17:02 (1) Answers

runpath not in xcode settings

I am having a lot of issues with cocoapods where, doing pod install installs the correct library / framework. And I can reference it in code. However, during compile time, I get linker errors, where even I reference the pod frameworks. If I manually ...
more »

2017-02-28 14:02 (0) Answers