google maps api sdk version error?

Question

It's my code sample. When I firstly build my code, it results in so-called dex error. I added multiDexEnabled property to my gradle setting, but it results in java heap memory overflow. I increased its max size, and finally got builded. However, another error occurred...... what is the problem? android adk version?

apply plugin: 'com.android.application'

android {
    compileSdkVersion 24
    buildToolsVersion "24.0.2"

    defaultConfig {
        applicationId "belobster.earthquakealert"
        minSdkVersion 14
        targetSdkVersion 24
        versionCode 1
        versionName "1.0"
        multiDexEnabled true
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    dexOptions {
        javaMaxHeapSize "2g"
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:24.2.1'
    compile 'com.google.android.gms:play-services:9.6.1'
}

emulator image.

genymotion emulator displaying google maps error


Show source
| gradle   | android   | google-maps   | adk   2016-10-21 13:10 3 Answers

Answers ( 3 )

  1. 2016-10-21 13:10

    Check whether play services is available on the emulator, you should consider using physical device for these kind of testing purposes since maps require location services quite often.

  2. 2016-10-21 13:10

    download gapps-lp-20141109-signed and install in genymotion

  3. 2016-10-21 13:10

    If you want to test it into Genymotion only then , Genymotion provide support for play service

    So please check it. It's work for me. Thank you.

◀ Go back