Keep getting error incompatible library version libchtslib.so requires version 9.0.0 or later, but libcurl.4.dylib provides version 7.0.0

Question

I am trying to install a program called metaBIT. I was able to add it to my PATH. But when I execute:

metaBIT -h 

It errors and gives me this:

Traceback (most recent call last):
File "/Users/twpierson/edirect/metaBIT", line 12, in <module>
import pysam
File "//anaconda/lib/python2.7/site-packages/pysam/__init__.py", line 5, in       <module>
from pysam.libchtslib import *
ImportError: dlopen(//anaconda/lib/python2.7/site-  packages/pysam/libchtslib.so, 2): Library not loaded: libcurl.4.dylib
 Referenced from: //anaconda/lib/python2.7/site-packages/pysam/libchtslib.so
 Reason: Incompatible library version: libchtslib.so requires version 9.0.0    or later, but libcurl.4.dylib provides version 7.0.0

I have tried every available suggestion on this error using google search.

I attempted to uninstall and reinstall pysam.

pip uninstall pysamp 
pip install pysam

I still get the same error. Please help!


Show source
| osx   | python   | pip   | terminal   | pysam   2017-01-06 18:01 1 Answers

Answers to Keep getting error incompatible library version libchtslib.so requires version 9.0.0 or later, but libcurl.4.dylib provides version 7.0.0 ( 1 )

  1. 2017-01-06 19:01

    I would recommend installing the MacPorts or Homebrew version of cURL:

    $ sudo port install curl
    

    This will install the latest version of cURL (7.52.1 at this time) using MacPorts in /opt/local/bin/curl. MacPorts should do all the linking needed to use this latest version of cURL with macOS/OS X. After installing you can check the libcurl.4.dylib version by:

    $ cd /opt/local/lib
    $ otool -L libcurl.4.dylib
    libcurl.4.dylib:
        /opt/local/lib/libcurl.4.dylib (compatibility version 9.0.0, current version 9.0.0)
        /opt/local/lib/libssl.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
        /opt/local/lib/libcrypto.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
        /opt/local/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.8)
        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1238.0.0)
    

Leave a reply to - Keep getting error incompatible library version libchtslib.so requires version 9.0.0 or later, but libcurl.4.dylib provides version 7.0.0

◀ Go back