Cannot disable SASS cache

Question

I cannot prevent my /.sass-cache directory from being created.

I am attempting this by running:

sass --no-cache

However running that doesn't do anything. When I pull up the help flag, this is what I get:

Miscellaneous:
    -i, --interactive                Run an interactive SassScript shell.
    -c, --check                      Just check syntax, don't evaluate.
        --precision NUMBER_OF_DIGITS How many digits of precision to use when outputting decimal numbers.
                                     Defaults to 5.
        --cache-location PATH        The path to save parsed Sass files. Defaults to .sass-cache.
    -C, --no-cache                   Don't cache parsed Sass files.
        --trace                      Show a full Ruby stack trace on error.
    -q, --quiet                      Silence warnings and status messages during compilation.

After seeing this, I then tried sass -C, --no-cache but got this error:

OptionParser::InvalidOption: invalid option: -, Use --trace for backtrace.

How do I disable the creation of the ./sass-cache folder?


Show source
| caching   | css   | sass   2017-08-08 21:08 1 Answers

Answers to Cannot disable SASS cache ( 1 )

  1. 2017-08-08 21:08

    Use

    sass -C
    

    or

    sass --no-cache
    

    but not both.

    If using config.rb, then add:

    asset_cache_buster = :none 
    cache = false
    

Leave a reply to - Cannot disable SASS cache

◀ Go back